Flash/Javascript detection failed.

We're sorry, but the NextTEN Budget Challenge Requires
Flash Version 8 or higher
and Javascript.

Please:
(1) upgrade your Flash Player (it's free and usually very fast)
(2) Ensure that Javascript is turned on in your browser.
(3) Reload this page.

If you believe you've hit this message in error, please feel free to attempt to bypass the detection and proceed to the challenge (Javascript MUST be turned on anyway).


Minimum System Requirements:

Windows 2000, Windows XP, Windows Vista
Firefox 1.x, Internet Explorer 6.0, Mozilla 1.x, Netscape 7.x

Mac OS X v10.2
Firefox 1.x, Mozilla 1.x, Netscape 7.x, Safari 1.x

Please note that Internet Explorer on the Macintosh does not support Flash Player 8.